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BizInsight 5.0.35.2

Installing Additional Content

This document applies to the following ERP system(s):

AccountMate Microsoft Dynamics GP Sage 500
Acumatica Microsoft Dynamics SL Sage X3v5
Alere QAD EE Sage X3v6
CCH QAD SE SAP B1
Deltek Vision Ross Syspro
FiresStream Sage 300 Traverse

Table of Contents

Step 1: Run Content Installer for Additional Content Pack(s) 1

Step 2: Updating Client Workstations 9

Appendices 12

Implementing Additional BizInsight Content on a Citrix/Terminal Services Server 13

Manually Installing BizContent Add-ins 14

Resolving “.xll could not be found” errors 26



BizInsight
5.0.35.2

Installing Additional Content: Step 1: Run Content Installer for Additional
Content Pack(s)

BizNet Software, Inc 1| Page

Step 1: Run Content Installer for Additional Content
Pack(s)

1. The Welcome dialog will open.  Click Next.

2. Review the End User License Agreement and if you agree to the terms, check the I
accept the terms in the License Agreement checkbox and click Next.
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3. Click on the desired Setup Type button.

Custom setup type options that are available:
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4. Click Install.

5. Click Yes to any User Account Control messages.

6. When the installer completes, an icon will exist on the desktop if you did not dis-
able the creation of shortcuts.

7. Double-click the shortcut on the desktop to launch the content installer.  If you
chose a Custom installation and disabled the creation of shortcuts, you must
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browse to the directory to which the content installer files were extracted and
double-click the BizNet Content Installer.exe. If you installed to the default dir-
ectory location, that directory can be found in C:\Program Files (x86)\BizNet Soft-
ware.

8. The content installer will inspect the server and determine what elements already
exist and indicate their presence with a green check mark.

9. Click on the Relevant Information link in the upper right corner and make a note
of the Report Folder name:

Note  If the Relevant Information dialog does not contain any information and
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BizInsight is already installed, go to a workstation where BizInsight is installed.
Open Excel on the workstation, click on the Application Settings button on the
BizInsight ribbon and copy the values provided for the Configuration Path, the
Administration Path, the Default Reporting Services Server and the Default
Reporting Services Folder Name fields.

10. Click Automatic Install.

11. The content installer will deploy the MetaData and function content.  The path
will be automatically defaulted to the path last used.  Click OK.

12. The content installer will open the content deployment dialog.  Most paths will
not need to be changed.  But you must check the following to make sure they are
correct:

a. Make sure the folder name is the folder name currently being used. If the
folder is not the same as shown in the Relevant Information dialog,
change that field to match the folder that is currently being used.
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b. Adjust the Server Name field if your accounting system database is on
another server. NOTE  The server name will default to the last server used.
This may not be the right server for the content pack being deployed.

c. Adjust the Database Name field to point to your accounting system data-
base. If your accounting software uses a system or control database,
provide the name of that database rather than a company database name.
NOTE  The database name will default to the last database used. This may
not be the right database for the content pack being deployed.

13. Select the desired authentication method – Windows authentication or Prompt
for Credentials. 

 IMPORTANT  You must use the same authentication method as selected for
other content packs.

14. Click Deploy Content.
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15. The content installer will display a status message to indicate that it is working.

16. Once complete, the installer will display links to the Reporting Services sites. 
Click OK to continue with the installation.

17. The License Administration Tool will open.  Unless you need to add new users,
click Exit.

18. The content installer window will display the results of the automatic install. 
Click Close.
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19. Click Exit to close the content installer.

20. Repeat the above steps for each content pack that needs to be installed.
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Step 2: Updating Client Workstations

Once all BizContent updates have been updated on the server, each client workstation
installation needs to be updated with the new content add-in files and BizInsight
Desktop Edition installed if the new content pack is a System Connector.

If BizInsight is being used in a Citrix/Terminal Services environment, see "Implementing
Additional BizInsight Content on a Citrix/Terminal Services Server" on page 13.

If BizInsight is installed on individual workstations, instruct all BizInsight users to click
on the Scan for Content button on the BizInsight ribbon in Excel to update their work-
stations with the new content.

If the users report that the Scan for Content button is missing, they may not have the
most current BizInsight version. The Scan for Content button was added in version
5.0.34.  BizNet Software recommends downloading and installing the latest BizInsight ver-
sion but if you must use an older version, see "Manually Installing BizContent Add-ins"
on page 14.

If your users report an error similar to the following when opening Excel again, see
"Resolving “.xll could not be found” errors" on page 26 for steps to resolve.

Install BizInsight Desktop Edition

If you are implementing a System Connector release, the BizInsight Desktop Edition
product must installed on the client workstation, if it is not already present.

1. Download the BizInsight Desktop Edition product from the customer portal site,
http://biznet.flexnetoperations.com.

2. Extract the contents and double-click the setup.exe

http://biznet.flexnetoperations.com/
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3. The installer will prompt to download the BizNet API. Click Install.

IMPORTANT

If the .msi is run before running the setup.exe, the following error will occur:

4. If a User Account Control dialog opens, click Yes.
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5. The End User License Agreement dialog will open. Review the license terms and if
you agree with the terms, select the I agree radio button and click Install.

6. Click Finish when the installation completes.
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Implementing Additional BizInsight Content on a Citrix/Terminal Ser-
vices Server

1. Copy all new BizContent add-in files (.dll, .dna and .xll) from the Configuration
Path to the local BizInsight directory. If you do not know the location of the Con-
figuration Path, launch the Content Installer on the server and click on the Rel-
evant Information link in the upper right of the dialog.

2. Browse to the reg5 subdirectory of the local BizInsight directory. Open the file
named "Excelxxxx_register_OnDemand.reg" with Notepad.

3. Copy the last Openn entry in this file and paste directly below. Increment the
Openn and change the name to the new BizContent .xll file name. Repeat for each
new content .xll file until all are represented in the file. For example:

"OPEN"="/A \"BizInsightXL.Foundation\""
"OPEN1"="/R \"C:\\BizInsight\\BizNetERPGL.xll\""
"OPEN2"="/R \"C:\\BizInsight\\MAS500GL.xll\""
"OPEN3"="/R \"C:\\BizInsight\\MAS500AR.xll\""

4. Save your changes to the file.

5. Browse to the reg5 subdirectory of the BizInsight directory and execute the
"Register BizInsight for Excel xxxx OnDemand.bat" file to make sure it runs
without error.

6. Have each BizInsight user execute the "Register BizInsight for Excel xxxx OnDe-
mand.bat" to register the additional content for their login.
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Manually Installing BizContent Add-ins

If you are using a BizInsight version that is older than 5.0.34, you will need to register the
BizContent add-ins manually in Excel. BizNet Software recommends upgrading to the
latest BizInsight version but if that is not possible, perform the following steps:

1. Browse to the BizInsight shared directory and copy the content add-in files (.dll,
.xll and .dna) to the directory to which you installed the BizInsight client.  If you
are using separate config and admin folders, the client add-in files will be in the
config folder.

The remaining steps vary based on the Office version installed:

Office 2010/2013 steps
Excel 2007 steps
Excel 2003 steps

Excel 2010/2013

1. Click on File > Options.
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7. Click on Add-ins in the left pane and then click on Go at the bottom on the
right pane.
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2. In the Add-ins dialog, click on the Browse button.

3. Browse to the directory to which you installed BizInsight and select the .xll
file in that directory.  Then click OK.



BizInsight 5.0.35.2 Installing Additional Content: Appendices

BizNet Software, Inc 18| Page

The Add-ins dialog should now look like the following:

4. Click OK.
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Excel 2007

1. Click on the Office button and then click on the Excel Options button.
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2. Click on Add-ins in the left pane and then click on Go at the bottom on the
right pane.
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3. In the Add-ins dialog, click on the Browse button.

4. Browse to the directory to which you installed BizInsight and select the .xll
file in that directory.  Then click OK.
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The Add-ins dialog should now look like the following:

5. Click OK.
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Excel 2003

1. Click on Tools > Add-Ins



BizInsight 5.0.35.2 Installing Additional Content: Appendices

BizNet Software, Inc 24| Page

2. In the Add-ins dialog, click on the Browse button.

3. Browse to the directory to which you installed BizInsight and select the .xll
file in that directory.  Then click OK.
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The Add-ins dialog should now look like the following:

4. Click OK.
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Resolving “.xll could not be found” errors

In some rare instances, the name of the content add-in file provided with an update may
change. When an add-in file name is changed, Scan for Content will properly remove
that add-in file but will not delete the pointer to it that resides within Excel and the fol-
lowing error will occur:

Perform the following steps to resolve the issue:

The remaining steps vary based on the Office version installed:

Office 2010/2013 steps
Excel 2007 steps
Excel 2003 steps

Excel 2010/2013

1. Click on File > Options.
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7. Click on Add-ins in the left pane and then click on Go at the bottom on the
right pane.
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2. In the Add-ins dialog, click on the Browse button.

3. Browse to the directory to which you installed BizInsight and select the .xll
file in that directory.  Then click OK.
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The Add-ins dialog should now look like the following:

4. Click OK.
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Excel 2007

1. Click on the Office button and then click on the Excel Options button.
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2. Click on Add-ins in the left pane and then click on Go at the bottom on the
right pane.
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3. In the Add-ins dialog, click on the Browse button.

4. Browse to the directory to which you installed BizInsight and select the .xll
file in that directory.  Then click OK.
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The Add-ins dialog should now look like the following:

5. Click OK.
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Excel 2003

1. Click on Tools > Add-Ins
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2. In the Add-ins dialog, click on the Browse button.

3. Browse to the directory to which you installed BizInsight and select the .xll
file in that directory.  Then click OK.
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The Add-ins dialog should now look like the following:

4. Click OK.

9. Once in the add-ins dialog, uncheck the add-in mentioned in the error message.
You should get the following message.  Click Yes.  If you do not get this message,
you have unchecked the wrong add-in.  Re-check it and uncheck the next one
that is shown that has a similar name.
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10. Close and reopen Excel to confirm that the error no longer occurs.
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